aboutsummaryrefslogtreecommitdiff
path: root/tests/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2014-04-29 08:29:49 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2014-04-29 08:29:49 +0200
commit871082dc018815261b6ec75a8e4933505389ffae (patch)
tree6b92641afc8dbbf234fa5b46569ed4335cb4204b /tests/template/Makefile.am
parenteb95d50569946def5e55c73445c1d85f603e8536 (diff)
Support for autotools and VC++ 9, 10, 11 build systems
Diffstat (limited to 'tests/template/Makefile.am')
-rw-r--r--tests/template/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/template/Makefile.am b/tests/template/Makefile.am
new file mode 100644
index 0000000..9d198f1
--- /dev/null
+++ b/tests/template/Makefile.am
@@ -0,0 +1,15 @@
+# file : tests/template/Makefile.am
+# copyright : not copyrighted - public domain
+
+EXTRA_DIST = __file__(extra_dist)
+
+noinst_PROGRAMS = driver
+driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
+LDADD = $(top_builddir)/xml/libstudxml.la
+
+AM_CPPFLAGS = -I'$(top_builddir)' -I'$(top_srcdir)'
+
+TESTS=$(top_builddir)/tester
+TESTS_ENVIRONMENT=example=; export example;
+
+CLEANFILES = test.out