aboutsummaryrefslogtreecommitdiff
path: root/libstudxml/Makefile.am
diff options
context:
space:
mode:
authorKaren Arutyunov <karen@codesynthesis.com>2017-05-02 21:26:58 +0300
committerKaren Arutyunov <karen@codesynthesis.com>2017-05-02 23:55:21 +0300
commit424e315dfa9a78aebf0653c95f83fe6ed452dd8e (patch)
tree59759d1d4eac4096df104d4dbab24a531ada3399 /libstudxml/Makefile.am
parent3d2b5b2a7064abe35614ebb32db03bd2881adcf0 (diff)
Add hxx extension for headers and libstud prefix for library dir
Diffstat (limited to 'libstudxml/Makefile.am')
-rw-r--r--libstudxml/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/libstudxml/Makefile.am b/libstudxml/Makefile.am
new file mode 100644
index 0000000..531d456
--- /dev/null
+++ b/libstudxml/Makefile.am
@@ -0,0 +1,31 @@
+# file : xml/Makefile.am
+# copyright : Copyright (c) 2013-2017 Code Synthesis Tools CC
+# license : MIT; see accompanying LICENSE file
+
+EXTRA_DIST = __file__(extra_dist)
+
+studxmlincludedir = $(includedir)/xml
+
+lib_LTLIBRARIES = libstudxml.la
+libstudxml_la_SOURCES = __path__(sources)
+
+nobase_studxmlinclude_HEADERS = __path__(headers)
+nobase_nodist_studxmlinclude_HEADERS = details/config.h
+
+if !LIBSTUDXML_EXTERNAL_EXPAT
+libstudxml_la_SOURCES += __path__(expat_sources)
+nobase_studxmlinclude_HEADERS += __path__(expat_headers)
+endif
+
+libstudxml_la_SOURCES += __path__(genx_sources)
+nobase_studxmlinclude_HEADERS += __path__(genx_headers)
+
+nobase_studxmlinclude_HEADERS += __path__(xml_headers)
+
+# Make sure make doesn't try to build the no-extension headers
+# thinking that they are executable.
+#
+__foreach_w__(__f,__path__(xml_headers),__f $(top_srcdir)/xml/__f ): ; @:
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -DLIBSTUDXML_DYNAMIC_LIB
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined