aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2011-02-18 15:54:04 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2011-02-18 15:54:04 +0200
commit3cc7d6569990cfb4fae913e1ea0e56c1e80c2246 (patch)
tree8497cdc478a6585ce8997adda141188f7a71e1b9 /configure.ac
parenta9a87afc39f815024b1908473a3ed33a82ddd25e (diff)
Add support for default options file
Now, if configured, the ODB compiler will load the default options file (../etc/odb/default.options by default). This file can be used for installation-wide customization, such as adding extra include search paths.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a680089..7dc7e0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ AS_IF([test x$static_plugin = xyes],
#
AS_IF([test x$static_plugin = xno], GCC_PLUGIN)
-#
+# G++ name.
#
AC_ARG_WITH(
[gxx-name],
@@ -53,6 +53,27 @@ AS_IF(
[test "x$gxx_name" != x],
[AC_DEFINE_UNQUOTED([GXX_NAME], ["$gxx_name"], [g++ binary.])])
+# Default options file.
+#
+AC_ARG_WITH(
+ [options-file],
+ [AC_HELP_STRING([--with-options-file=PATH], [default options file path to embed in the driver])],
+ [case $withval in
+ no)
+ options_file=
+ ;;
+ yes)
+ options_file=../etc/odb/default.options
+ ;;
+ *)
+ options_file="$withval"
+ ;;
+ esac],
+ [options_file=])
+
+AS_IF(
+ [test "x$options_file" != x],
+ [AC_DEFINE_UNQUOTED([DEFAULT_OPTIONS_FILE], ["$options_file"], [default options file path.])])
# Create the libtool executable so that we can use it in further tests.
#