aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-02-28 12:38:15 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-02-28 12:38:15 +0200
commit3012187847b2783c49153db3f5486b84074cb2b0 (patch)
tree8d3b63fbea88f2cb530dc6f8121577856b4f37b8 /configure.ac
parent3c13e8cd7a1b0bf7490b172b48424a91b126c650 (diff)
Build infrastructure for C++11 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5d5d213..50f2122 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,10 @@ AS_IF([test x$threads = xposix], AC_DEFINE([ODB_THREADS_POSIX], [1], [Have POSIX
AS_IF([test x$threads_thread_keyword = xyes], AC_DEFINE([ODB_THREADS_TLS_KEYWORD], [1], [Have __thread keyword.]))
+# Check for C++11.
+#
+CXX11([ODB_CXX11], [Compiling in the C++11 mode.])
+
# Define LIBODB_STATIC_LIB if we are build static library on certain platforms.
#
STATIC_LIB([LIBODB_STATIC_LIB], [Static library interface.])