aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-14 15:13:43 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-14 15:13:43 +0200
commitf7c9c07973ff5a1041036478fcae87f77457d737 (patch)
tree53c048a7b1f9a06af8d3ce029ac77451a5beeb8f /configure.ac
parentf7bf16d50f6f08c66b1bae35e2dab327d560b0f3 (diff)
Use __thread keyword if available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1e7cfa..eb71db7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,8 @@ AS_IF([test x$threads = xnone], AC_DEFINE([ODB_THREADS_NONE], [1], [Have no thre
AS_IF([test x$threads = xwin32], AC_DEFINE([ODB_THREADS_WIN32], [1], [Have Win32 threads.]))
AS_IF([test x$threads = xposix], AC_DEFINE([ODB_THREADS_POSIX], [1], [Have POSIX threads.]))
+AS_IF([test x$threads_thread_keyword = xyes], AC_DEFINE([ODB_THREADS_TLS_KEYWORD], [1], [Have __thread keyword.]))
+
# Define LIBODB_STATIC_LIB if we are build static library on certain platforms.
#
STATIC_LIB([LIBODB_STATIC_LIB], [Static library interface.])