aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-08-26 14:52:12 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-08-26 14:52:12 +0200
commit6fb470a39ef8900b71634333b0a2227dc8b62799 (patch)
tree6d782be7a2b25c3f21e9d25f7c7251bde2699994 /Makefile.am
parentc883d0ba2f4450f35de6767355555fa83e6262ea (diff)
Add support for creating other build systems (meta-building)
Add support for automake, VC++ 9, and VC++ 10. Also add the Win32 and 'NULL' threading model implementations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..7a607bc
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,12 @@
+# file : Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+SUBDIRS = __path__(dirs)
+dist_doc_DATA = __file__(docs)
+EXTRA_DIST = __file__(extra_dist)
+ACLOCAL_AMFLAGS = -I m4
+
+pkgconfigdir = @pkgconfigdir@
+pkgconfig_DATA= libodb.pc