aboutsummaryrefslogtreecommitdiff
path: root/odb/sqlite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'odb/sqlite/Makefile.am')
-rw-r--r--odb/sqlite/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/odb/sqlite/Makefile.am b/odb/sqlite/Makefile.am
new file mode 100644
index 0000000..238583d
--- /dev/null
+++ b/odb/sqlite/Makefile.am
@@ -0,0 +1,16 @@
+# file : odb/sqlite/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb-sqlite.la
+libodb_sqlite_la_SOURCES = __path__(sources)
+
+odbsqliteincludedir = $(includedir)/odb/sqlite/
+nobase_odbsqliteinclude_HEADERS = __path__(headers)
+nobase_nodist_odbsqliteinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)' -DLIBODB_SQLITE_DYNAMIC_LIB
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined