aboutsummaryrefslogtreecommitdiff
path: root/odb/pgsql/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'odb/pgsql/Makefile.am')
-rw-r--r--odb/pgsql/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/odb/pgsql/Makefile.am b/odb/pgsql/Makefile.am
new file mode 100644
index 0000000..2c61b75
--- /dev/null
+++ b/odb/pgsql/Makefile.am
@@ -0,0 +1,16 @@
+# file : odb/pgsql/Makefile.am
+# author : Constantin Michael <constantin@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb-pgsql.la
+libodb_pgsql_la_SOURCES = __path__(sources)
+
+odbpgsqlincludedir = $(includedir)/odb/pgsql/
+nobase_odbpgsqlinclude_HEADERS = __path__(headers)
+nobase_nodist_odbpgsqlinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)' -DLIBODB_PGSQL_DYNAMIC_LIB
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined