aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e2834da..0060d99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,9 +28,14 @@ LT_OUTPUT
#
THREADS
+# Check for boost.
+#
+LIBBOOST([],[AC_MSG_ERROR([boost is not found; consider using CPPFLAGS/LDFLAGS or --with-boost=DIR to specify its location])])
+LIBBOOST_SYSTEM
+
# Check for libodb.
#
-LIBODB([],[AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
# Define LIBODB_BOOST_STATIC_LIB if we are build static library on certain
# platforms.