aboutsummaryrefslogtreecommitdiff
path: root/cutl/Makefile.am
diff options
context:
space:
mode:
authorKaren Arutyunov <karen@codesynthesis.com>2020-12-16 20:29:05 +0300
committerKaren Arutyunov <karen@codesynthesis.com>2021-02-24 16:40:04 +0300
commit8e761289a2446367267c6c0d9a26e734f0f78306 (patch)
treefb495d8c18801f271d124ee48731f10df396ca89 /cutl/Makefile.am
parent4c8104756b92b9fa16b3a725e8a6aa620dfd606e (diff)
Get rid of legacy build systems and rename cutl/ to libcutl/
Diffstat (limited to 'cutl/Makefile.am')
-rw-r--r--cutl/Makefile.am27
1 files changed, 0 insertions, 27 deletions
diff --git a/cutl/Makefile.am b/cutl/Makefile.am
deleted file mode 100644
index 060b132..0000000
--- a/cutl/Makefile.am
+++ /dev/null
@@ -1,27 +0,0 @@
-# file : cutl/Makefile.am
-# license : MIT; see accompanying LICENSE file
-
-EXTRA_DIST = __file__(extra_dist)
-
-cutlincludedir = $(includedir)/cutl
-
-lib_LTLIBRARIES = libcutl.la
-libcutl_la_SOURCES = __path__(sources)
-
-nobase_cutlinclude_HEADERS = __path__(headers)
-nobase_nodist_cutlinclude_HEADERS = details/config.h
-
-if !LIBCUTL_EXTERNAL_BOOST
-libcutl_la_SOURCES += __path__(boost_sources)
-endif
-
-if !LIBCUTL_EXTERNAL_EXPAT
-libcutl_la_SOURCES += __path__(expat_sources)
-nobase_cutlinclude_HEADERS += __path__(expat_headers)
-endif
-
-libcutl_la_SOURCES += __path__(genx_sources)
-nobase_cutlinclude_HEADERS += __path__(genx_headers)
-
-AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -DLIBCUTL_DYNAMIC_LIB
-AM_LDFLAGS = -release __value__(interface_version) -no-undefined