aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-14 19:01:49 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-14 19:01:49 +0200
commit19d0eb2adcda31d9919bca8fef98cb1871b4ce54 (patch)
tree2e37fd2a976d6ec1f5fa1c49da8c2e5a04dfa440 /configure.ac
parent6aeb2e06e9fa137a8e26f8605ec63f7567e65280 (diff)
Add automake and VC++ builds (meta-build)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e45f845
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,41 @@
+# file : configure.ac
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : MIT; see accompanying LICENSE file
+
+AC_PREREQ(2.60)
+AC_INIT([libcutl], [__value__(version)], [libcutl-users@codesynthesis.com])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([cutl/exception.hxx])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc subdir-objects dist-bzip2 dist-zip tar-ustar])
+
+LT_INIT([win32-dll])
+
+AC_CANONICAL_HOST
+
+# Check for C++ compiler and use it to compile the tests.
+#
+AC_PROG_CXX
+AC_LANG(C++)
+
+# Create the libtool executable so that we can use it in further tests.
+#
+LT_OUTPUT
+
+# Allow the user to specify the pkgconfig directory.
+#
+PKGCONFIG
+
+# Check if we should disable rpath.
+#
+DISABLE_RPATH
+
+# Output.
+#
+AC_CONFIG_HEADERS([cutl/config.h cutl/details/config.h])
+AC_CONFIG_FILES([
+ __path__(config_files)
+])
+AC_OUTPUT